The incident has been resolved, and all affected services have returned to normal operation. Our team will continue to monitor service performance to ensure ongoing stability. If you experience any unexpected issues, please contact our support team through the appropriate channels. Incident End: [15/07/2026 – 18: 40 UTC-6]
Posted Jul 15, 2026 - 18:56 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2026 - 17:45 CST
Investigating
We have identified an issue affecting one of our payment service providers antifraud. Some merchants may experience disruptions in payment processing, imeouts, increased latency, failed attempts, or delayed confirmations. Our teams are actively working with the provider to investigate and mitigate the issue. This page will be updated as new information becomes available. Incident Start: [15/07/2026 – 17:16 UTC-6]