Degradation in service

Incident Report for DEUNA Production

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 11:04 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2026 - 18:45 CST

Update

We are continuing to work on a fix for this issue.

The data recovery process is advancing as scheduled.

Recent Orders: Visibility for transactions from the last 30 days will be fully restored for all merchants within the next 60 minutes.

Historical Data: Indexing for previous months is ongoing, and this information will become available progressively over the next few hours.

We appreciate your patience as we normalize access to historical records.
Posted Feb 19, 2026 - 12:00 CST

Identified

We are currently experiencing a degradation in the Admin service.

This situation does not impact transaction processing; however, there are issues when attempting to view the order history.

We are currently investigating and will provide updates as soon as more information becomes available.
Posted Feb 19, 2026 - 10:17 CST
This incident affected: ADMIN (Orders).